Forums ePic Character Generator Technical Discussion Bug Report claim for free not working

  • This topic has 50 replies, 17 voices, and was last updated 1 day ago by LBandy.
Viewing 15 posts - 1 through 15 (of 51 total)
  • Author
    Posts
  • #26012
    farandall
    Participant

    I don’t see how to get the “claim for free” packages to work. I tried logging in through the Chrome browser and edge, but I only see a purchase option.

    #26022
    LBandy
    Keymaster

    Hi farandall,

    You can claim your free packages on your Profile page. If you have a free pack available, you will see the “Claim for free” text under the character image. Click that, and it should be added to your account. Please let me know if there are any issues.

    #26507
    thaladar
    Participant

    I am having the same issue. I see 4 free packs but nothing too choose from

    #26531
    LBandy
    Keymaster

    Hi thaladar,

    On your Profile page you should be seeing something similar:

    By clicking Claim for free!, you should be able to exchange your free pack to the ones of your choice.

    Please let me know if you still face any issues!

    #26988
    SRSilv
    Participant

    Hello. I’m a new user of the software. Finishing the tutorial brought me to the achievements and profile page to claim a pack. But, I have none that say “Claim for Free” and apparently it says that there are 0 packs to claim.  Is the tutorial message an old out-of-date message in the ePic tutorial?

    #26995
    LBandy
    Keymaster

    Hi SRSilv, welcome to our forums!

    Actually the tutorial free pack message is one of the newest features in the software. Once you completed the tutorial, a free pack is added to your account, if you are logged into one in the software. If not no worries, just enter the same credentials on the login screen you used when registering to the site. Once logged in, you should be able to claim a pack of your choice on your Profile page. If you are using the Steam or Google Play versions make sure to untick Steam/Google Auth before logging in. Also clicking the “Earn more” button on the free pack counter will perform an automatic account linking if necessary.

    I hope this helps, but please let us know if you face any issues.

    #28354
    Marsyb
    Participant

    I just downloaded this and got a free pack available for doing the tutorial but am facing the same issue, the checkbox on my profile page says that I completed the tutorial and my home screen in the application shows 1 available free pack at the bottom but the profile page says 0 free packs available and all the character images say not owned under them and none say claim for free.

    #28364
    Kelemelan
    Participant

    When you log into your profile page here https://overheadgames.com/epic-character-generator/profile/ it doesn’t list your free packs ?

    #28371
    LBandy
    Keymaster

    Hi Marsyb!

    You use the standalone version downloaded from the website, right? I checked our backend and I don’t see the tutorial being complete on your profile. Can you double check that you are logged in the software? You can press Login when in the main menu, then make sure to enter the same credentials you used when registering here. Once logged in, the tutorial achievement should unlock on your Profile, and you should be able to claim your pack for free. Logging in is necessary otherwise we don’t know who to give the free pack to, and also once you unlock or purchase a pack, the software won’t know you own them. 🙂 Does this make sens?

    I hope this helps, but please let us know if there’s any other issues.

    #29550
    bennowak
    Participant

    I have followed all the instructions, grabbed the “Claim for free” per the mail and in my profile it shows as “Owned”..  but it does NOT show up in the editor as owned/active.

    What am I doing wrong?

    #29551
    LBandy
    Keymaster

    Hi bennowak,

    Did you log in to the software? When you are in the main menu, press the Login button, enter the same username and password you used on our site, and press the Login button again.

    Let me know if it still doesn’t work for some reason. 🙂

    #30160
    xN4KEDP0TAT0x
    Participant

    I’ve downloaded the game, followed all the steps to link my Steam account, tried all the advice from this forum, but it’s still not working. I have done the tutorial now seven times and nothing.

    #30162
    LBandy
    Keymaster

    Hello there,

    I just checked our backend and it seems the Steam account linking hasn’t been successful.

    Linking Steam account is really easy, just follow the steps described here: https://overheadgames.com/epic-character-generator/steam-account-linking-guide/

    Also, make sure to untick Steam Auth before pressing Login.

    #30178
    Jeffm9770
    Participant

    I did the tutorial and claimed the Ork pack. It shows I own it on my profile but none of the character options have changed beyond the Demo in the actual character generator. Os there something else I have to do? Never mind I found it

    #30179
    LBandy
    Keymaster

    Hi Jeff,

    Typically after you claim a package and go back to the software – if you are logged in – it should automatically detect your new packages and download them. You can always try to manually restart if this isn’t happening for you.

    I just checked our backend and I can confirm that the pack is associated with your account. I also see several successful logins from your end, so there shouldn’t be any issues. The pack is available under the Season #1 packs icon btw.

    Please let me know if you face any other issues.

Viewing 15 posts - 1 through 15 (of 51 total)
  • You must be logged in to reply to this topic.