Okay, first impressions….

    Firstly, wonderful voice. Wow!

    Secondly, the music at the start was a bit loud for me. I had to turn it down and then back up again when the narration began. I didn’t see a ‘settings’ menu yet. Is there one? Or, did I miss it? I do really like the music though. 🙂 ****UPDATE**** Made my Nira character and now I see ‘options’. Yay! I’m not sure what ME stands for though. Fiddling with the volume settings now.

    Some of the story doesn’t know I’m female.

    Is there a way to make it full screen?

    Is there a way to have the text advance with the voice?

    I died three times already. 😀 Just testing stuff. 😀 Gotta finish my lunch and then I’ll have a look again. 🙂